Opened 4 years ago

Last modified 4 years ago

#308 new defect

Connection problem

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Main Application Version: 0.8
Severity: minor Keywords:
Cc: Blocked By:
Blocking:

Description (last modified by stefan)

I have 7988-899:ERGORACE II and I cannot connect to the software.
Driver is on com3 (original sw is ok) but JErgonometr cannot obtain ID from device. (Windows 7 PROF. 64 bit)

Change History (5)

comment:1 Changed 4 years ago by Stanislav <Bilbob@…>

Is it possible I do something wrong?

comment:2 follow-up: Changed 4 years ago by stefan

I must admit that I never tested JErgometer on win 64.

Did the listing of available COM ports work for you or did you manually enter COM3?

Are you using a 64 bit java?

comment:3 in reply to: ↑ 2 Changed 4 years ago by anonymous

Listing of ports worked fine. When I change port listings shows the right one.
JAVA is 32 bit.
When ergonemeter 'sleeps' and I try connect, it wakes up, in console is "sending reset" and then (after while) cannot obtain ID from device error.
I will try 32 bit XP but I am afraid that Kettler made some changes in device.
I relly like your software because I won't like to pay for thinks I do not need (video) and even for time limited licence. I will be glad to donate reasonable money when it works fine.

comment:4 follow-up: Changed 4 years ago by stefan

  • Description modified (diff)
  • Version changed from 0.7 to 0.8

OK, but it's probably the combination of 32 bit Java and 64 bit Windows. I need to handle this case differently.

But I'm not completely sure if this will solve your issue. Therefore I filed a new bug report: #309

comment:5 in reply to: ↑ 4 Changed 4 years ago by Stanislav <Bilbob@…>

I have just tried XP32 bit and it is the same.

WARNING: RXTX Version mismatch

Jar version = RXTX-2.2pre1
native lib Version = RXTX-2.2pre2

Connection to ergometer failed at state "retrieveId"

It is the same for RXTX or Socat

Note: See TracTickets for help on using tickets.